Search

Apr 17, 2010

HTTP Error 404.17 - Not Found with IIS7 and WCF

Hello All,

I was running to same issue when I have installed VS2010 on Windows 7 after installing .NET on IIS 7.5. My WCF service was retuning me the following error when I try to hit my wcf service it will giving me following error.

HTTP Error 404.17 - Not Found

I tried to change application pool and switch form 2.0 classic to 4.0 class, and then it gives me one more error!

HTTP Error 500.19 – Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Error Code 0×800700b7
Config Error There is a duplicate ’system.web.extensions/scripting/scriptResourceHandler’ section defined

After doing some search I found out the fix of this, we just need to register service model using following command, you should run command prompt in administrator mode and then go to following directory.

$WindowsDir$\Microsoft.NET\Framework\v3.0\Windows Communication Foundation

And run this command in favor to register service model.

servicemodelreg –i

It will install machine configuration sections, handlers, assemblies, modules, protocols and lots of other thing to work things properly.

5 comments:

Nick said...

Good to know. Thanks Imran!

Anonymous said...

Thank you. Very useful.

Anonymous said...

Thank you. It helped me.

Anonymous said...

Thank you... this fixed my issue

Anonymous said...

thnx for the suggestion, it worked, i spent as much as 4 hours working on this to find a solution.